Adaptive |
Gets orientation type of an Adaptive Placement Point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static AdaptivePointOrientationType GetPointOrientationType(
Document doc,
ElementId refPointId
)
Parameters
Return Value
AdaptivePointOrientationTypeOrientation type of Adaptive Placement Point.

Exception | Condition |
---|---|
ArgumentException | The ElementId refPointId does not correspond to a valid ReferencePoint. -or- The Element corresponding to ElementId refPointId does not belong to an Adaptive Family. -or- The ElementId refPointId does not correspond to an Adaptive Placement Point. |
ArgumentNullException | A non-optional argument was null |