GetPoints Method


Point Cloud Instance Get Points Method

Extracts a collection of points based on a filter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public PointCollection GetPoints(
	PointCloudFilter filter,
	double averageDistance,
	int numPoints
)

Parameters

filter PointCloudFilter
The filter to control which points are extracted. The filter should be passed in the coordinates of the Revit model.
averageDistance Double
Desired average distance between "adjacent" cloud points (Revit units of length). The smaller the averageDistance the larger number of points will be returned up to the numPoints limit. Specifying this parameter makes actual number of points returned for a given filter independent of the density of coverage produced by the scanner.
numPoints Int32
The maximum number of points requested.

Return Value

PointCollection
A collection object containing points that pass the filter, but no more than the maximum number requested.
Exceptions
Exception Condition
ArgumentException The number of points read must range from 1 to 1000000.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The given value for averageDistance must be no more than 30000 feet in absolute value.
Remarks
If there are more points in the cloud passing the filter than the number requested in this function, the results may not be consistent if the same call is made again.
See Also