SetCycleCounter Method


Rebar Update Curves Data Set Cycle Counter Method

Sets the cycle counter to a specific value.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetCycleCounter(
	int cycleCounter
)

Parameters

cycleCounter Int32
Exceptions
Exception Condition
ArgumentOutOfRangeException The given value for cycleCounter is negative.
Remarks

The actual value is set into the rebar after the curves computation.

This function can be called to reset the counter to zero or to another value.

The cycle counter value is changed when the free form Rebar element is selected and the user press Space key -or- by through [!:Autodesk::Revit::DB::Structure::RebarRebarFreeFormAccessor::CycleCounter] property. -or- by the server if it considers that the counter reaches the maximum value and reset it (set it to 0).

See Also