HasAllChangesFromCentral Method


Document Has All Changes From Central Method

Returns whether the model in the current session is up to date with central.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool HasAllChangesFromCentral()

Return Value

Boolean
True means up to date; false means out of date.

If central is locked but Revit can determine that the model in the current session is out of date without opening central, this method will return false instead of throwing CentralModelContentionException.

Exceptions
Exception Condition
CentralFileCommunicationException The file-based central model could not be reached, because e.g. the network is down or the file server is down.
CentralModelAccessDeniedException Access to the central model was denied due to lack of access privileges. -or- Access to the central model was denied. A possible reason is because the model was under maintenance.
CentralModelContentionException The central model is locked by another client.
CentralModelException Username does not match the one used to create the local file. -or- The central model has been replaced by a local model. -or- Local incompatible because it was closed without saving after synchronizing with central. -or- The central model is missing. -or- The central model is incompatible. -or- The central model is corrupt or not an RVT file. -or- The central model was rolled back. -or- The central model's elements have been relinquished -or- The central model is overritten by other user. -or- An internal error happened on the central model, please contact the server administrator.
FileNotFoundException Cannot access the local file.
InvalidOperationException This Document is not a workshared document. -or- This Document is a local file that is not owned by the current user, who therefore is not allowed to modify it.
RevitServerCommunicationException The server-based central model could not be accessed because of a network communication error.
RevitServerInternalException An internal error happened on the server, please contact the server administrator.
RevitServerUnauthenticatedUserException User is not signed in with Autodesk id.
RevitServerUnauthorizedException User is not authorized to access the specified A360 project.
See Also