CanSuppressTrailingZeros Method (ForgeTypeId)


Format Options Can Suppress Trailing Zeros(Forge Type Id) Method

Checks whether trailing zeros can be suppressed for a given unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool CanSuppressTrailingZeros(
	ForgeTypeId unitTypeId
)

Parameters

unitTypeId ForgeTypeId
Identifier of the unit.

Return Value

Boolean
True if trailing zeros can be suppressed, false otherwise.
Exceptions
Exception Condition
ArgumentException unitTypeId is not a unit identifier. See UnitUtils.IsUnit(ForgeTypeId) and UnitUtils.GetUnitTypeId(DisplayUnitType).
ArgumentNullException A non-optional argument was null
See Also