IsValidSegmentId Method


Compound Structure Is Valid Segment Id Method

Determines whether the specified integer is actually the id of a segment in this CompoundStructure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsValidSegmentId(
	int segmentId
)

Parameters

segmentId Int32
The id of a segment in this CompoundStructure.

Return Value

Boolean
True if the specified segment is valid, false otherwise.
Exceptions
Exception Condition
InvalidOperationException This operation is valid only for vertically compound structures.
See Also