HermiteSpline Class


Hermite Spline Class

A Hermite spline.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class HermiteSpline : Curve

The HermiteSpline type exposes the following members.

Properties
Name Description
Public property ControlPoints The control points of the Hermite spline.
Public property IsPeriodic Returns whether the Hermite spline is periodic or not.
Public property Parameters Returns the params of the Hermite spline.
Public property Tangents Returns the tangents of the Hermite spline.
Top
Methods
Name Description
Public method Static member Create(IList XYZ , Boolean)
Public method Static member Create(IList XYZ , Boolean, HermiteSplineTangents)
Top
Remarks
The Hermite spline lies in the plane defined by control points.
See Also