RemoveLinkOverrides Method


View Remove Link Overrides Method

Deletes the graphical link overrides in the current view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void RemoveLinkOverrides(
	ElementId linkId
)

Parameters

linkId ElementId
The id of the RevitLinkType or RevitLinkInstance .
Exceptions
Exception Condition
ArgumentException The input id is not a valid RevitLinkInstance or RevitLinkType id.
ArgumentNullException A non-optional argument was null
InvalidOperationException The view type does not support Visibility/Graphics Overriddes. -or- The view does not support link graphical overrides.
Remarks
If the input linkId references RevitLinkType , then the link overrides will be set to default. If the input linkId references RevitLinkInstance , then the link overrides will be removed and the settings of RevitLinkType will be used for this instance.
See Also