FamilyCreate Property


Document Family Create Property

An object that can be used to create new instances of Autodesk Revit API elements within a family document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FamilyItemFactory FamilyCreate { get; }

Property Value

FamilyItemFactory
This object is used to create new instances of family elements within the Autodesk Revit API, such as Extrusion or Reference lines.
Exceptions
Exception Condition
InvalidOperationException Thrown when the current document is project document.
See Also