BuiltInFailures.GroupFailures Class


Built In Failures Group Failures Class

Failures related to groups and their behavior.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures GroupFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class GroupFailures

The BuiltInFailures GroupFailures type exposes the following members.

Properties
Name Description
Public property Static member AdditionalElementsRequired Grouping the selected elements requires that additional element(s) also be grouped. [Description] To satisfy the grouping requirement, these additional element(s) will be automatically added to the group as well.
Public property Static member AdditionalElementsRequiredRemove To be able to remove the selected elements from the group the following additional element(s) will also be removed: [Description]
Public property Static member AllElementsRemovedFromGroup Group "[Type Name]" is now empty and will be deleted.
Public property Static member AtomTouchedNotAllowed Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.
Public property Static member AtomTouchedNotAllowedDelete Changes to groups are only allowed during Edit Group mode. Use Edit Group to make this change.
Public property Static member AtomViolationWhenMultiPlacedInstances Changes to groups are allowed only in group edit mode. Use the Edit Group command to change to all instances of a group type. You may use the "Ungroup" option to proceed with this change by ungrouping the changed group instances.
Public property Static member AtomViolationWhenOnePlaceInstance A group has been changed outside group edit mode. The change is being allowed because there is only one instance of the type.
Public property Static member AttachedGroupNoMirror Attached detail groups cannot be mirrored without also mirroring their parent group.
Public property Static member AttachedGroupNoPasteToView An attached group cannot be pasted into the selected view type and has been omitted from the elements being pasted.
Public property Static member BadProblemWithGroup The operation performed affects groups in an unacceptable manner.
Public property Static member BadViewForAttachedGroup Attached groups can only be created for view specific elements belonging to non-3d model views.
Public property Static member BadViewForAttachedGroupWarn Attached groups can only be created for view specific elements belonging to non-3d model views.
Public property Static member CannotAddAlreadyMemberToDiffGroup Elements that are already members of one group cannot be added to another group.
Public property Static member CannotAddToGroupFormat [Element] cannot be added to the instance of [Group]
Public property Static member CannotAddToGroupFormatWarn [Element] cannot be added to the instance of [Group]
Public property Static member CannotCopyGroup Unable to copy the selected group.
Public property Static member CannotCreateGroup Cannot create group of these elements.
Public property Static member CannotCreateGroupWithInvalidReferences The elements you have selected for grouping contain dimensions or tags which do not reference a common model group. No detail group has been created.
Public property Static member CannotFinishGroupInSketchMode Can't Finish Group while in Sketch Mode.
Public property Static member CannotLinkAnnotationsForSomeViews Annotations for some views cannot be displayed from linked file.
Public property Static member CannotPlaceGroup Can't place Group from browser. Try copy/pasting existing copy of the Group instead.
Public property Static member CannotReloadWithFile Group [Type Name] cannot be reloaded from file [File Name].
Public property Static member CannotRemoveGroupMemberConstraint Constraints between group members cannot be removed or excluded from the group.
Public property Static member CannotRemoveGroupMemberConstraintWarn Constraints between group members cannot be removed or excluded from the group.
Public property Static member CannotRemoveSubordFromGroup Element can't be removed or excluded from the Group because it is required by another Group element.
Public property Static member CannotRemoveSubordFromGroupWarn Element can't be removed or excluded from the Group because it is required by another Group element.
Public property Static member CannotSaveGroup Can't save Group.
Public property Static member CannotSwapNestedGroups Can't replace because one Group is contained in the other.
Public property Static member ChildrenDeletedOnGroupSwap Some dependent elements were deleted by changing group type and cannot be retained.
Public property Static member ChildrenLostOnGroupSwap Some elements could not find new hosts after changing group type and will be deleted.
Public property Static member DetailsOfNestedGroupsLost Details will be deleted if they reference group members being ungrouped in other instances of this containing group.
Public property Static member DimensionsOrTagsReferecedRemoved Dimensions or Tags that reference non-group members have been removed from group [Name].
Public property Static member DimRefsGroupMemberSketch A group member's sketch or family is constrained to an element that is not a member of the group. These constraints have been removed.
Public property Static member DontEditNestedGroup Cannot edit nested Groups while inside Edit Group mode for its host Group. To edit the nested Group finish editing all Groups. Use the Tab key to select the nested Group and edit it directly.
Public property Static member ElementChangedMoreThanAllowed The Grouped element has changed length enough to make it substantially different from other Group instances. To make this degree of change Edit Group and make the change again.
Public property Static member ElementsContainsFabricationData Unable to load models containing elements with fabrication data as group.
Public property Static member ExcludedElementsRestoredInLink Excluded elements restored in the link.
Public property Static member FailedToChangeGroupLevelRef Unable to change group level ref.
Public property Static member FailedToSetLeaderGroupId Unable to set id of group type.
Public property Static member FailedToTransformAttachedGroup Attached group could not be properly relocated.
Public property Static member GroupAmongstLoadedRenamed A group or groups that was loaded was renamed because its name was not unique amongst the groups in the file being loaded. Most likely a model subgroup had the same name as the loaded file.
Public property Static member GroupCannotMixBackAndForegroundDetail This detail group contains some elements which display in the background and some which display in the foreground. Detail groups must be able to be displayed as a unit in either the foreground or background, so this type of mixture is not allowed.
Public property Static member GroupCannotSave The group cannot be saved at this time because one of its instances is being edited.
Public property Static member GroupCannotSaveWarn The group cannot be saved at this time because one of its instances is being edited.
Public property Static member GroupChangeNoPlaceElements Elements cannot be placed as a result of changes to groups.
Public property Static member GroupEditModeNoDuplicates Can't create duplicates in Edit Group mode.
Public property Static member GroupedModelElemHasViewSpecificSubordinates Unable to group the selected elements. Model element in group has view specific subordinates or view specific element in group has non-view specific subordinates.
Public property Static member GroupHadFailedElementsWhileUpdating Group members failed while updating group.
Public property Static member GroupPropagationFailedSketch Can't change Group"[Name]" with more than one instance because it has a Sketch-based element. Edit the Sketch of the element instead.
Public property Static member GroupPropagationFailedUngroup Can't make change to Group "[Type Name]" with more than one instance. To resolve: Ungroup and Group again under a new name. Edit and make change, then change all instances of the original Group to the new Group.
Public property Static member GroupPropagationUserCancelled Changes to Group "[Type Name]" have been cancelled.
Public property Static member GroupsHasCycle Can't create Group because it contains multiple copies of same Group.
Public property Static member GroupsHaveDifferentMembers Group instances of the same type do not contain identical members. Press "Fix Groups..." to select from options to make the groups consistent.\nCorresponding group members in different group instances diverge in the following respects:[Description]
Public property Static member GroupsNotCompatibleForTypeChange Some of the selected groups are not compatible with the new group type that was chosen.
Public property Static member GroupViewSpecificDiffViews You may not create a detail group with view specific elements from different views.
Public property Static member InvalidGroup This group is invalid.
Public property Static member LastCopyOfGroupDeleted Last copy of Group "[Name]" deleted. Group type removed from project.
Public property Static member LastGroupMemberExcluded Last member of group instance was excluded (deleted), removed, or moved to the project. Group instance has been deleted.
Public property Static member LinkVisibilityLost Link visibility overrides will be lost.
Public property Static member LoadOfGroupAbortedByUser You have aborted loading file '[File Name]' as a group.
Public property Static member MembersAlignWarn User parameter values for group members have been aligned.
Public property Static member MembersExcluded Group members have been excluded from this group instance.
Public property Static member MembersExcludedWarn Group members have been excluded from this group instance.
Public property Static member MembersMovedToProjectToMakeConsistent Group members had to be "moved to the project" (removed from their group instance) because they were not consistent with the group type definition.
Public property Static member ModifyingMultiGroups Multiple groups of the same type are being edited simultaneously outside group edit mode in an unacceptable manner.
Public property Static member MoveElemFailed Unable to move element.
Public property Static member NoAppropriateGroup There is no Group that can be placed in the current view.
Public property Static member NoDetailGroups There are no Detail Groups in this Project or Family.
Public property Static member NoModelGroups There are no Model Groups in this Project or Family.
Public property Static member NoneOfSelElemsGroupable None of the selected elements can be grouped. The elements may already be grouped or may be element types which are not allowed for grouping.
Public property Static member NoSwapGroupBeingEdited You may not change the type of the group that is currently being edited.
Public property Static member NotAGroupFile This is not a Group File.
Public property Static member NotAllGroupsFullyRestored Not all of the excluded members of the select groups were fully restored. You may be able to restore the remaining members individually or by performing "restore all excluded members" on sub-groups of the selected groups.
Public property Static member PlaceGroupFailed Unable to place group instances.
Public property Static member ProblemRegeneratingInGroupUpdate Unable to regenerate while updating groups at end of transaction.
Public property Static member ReferencesOutsideGroupAreNotAllowed The elements you have selected for grouping contain dimensions or tags whose references are not all included in the selection being grouped and are not all included in a common model group. As a result, some of the selected elements have not been included in the new group.
Public property Static member RemoveGroupSketchConstraintParent You are removing an element from the group which is involved in a sketch or family constraint with another element of the same group. Either remove the constraint or cancel the removal of this element from the group.
Public property Static member RemovingElemCannotBeGrouped Elements that cannot be grouped were removed from groups of type '[Type Name]'.
Public property Static member RemovingReferencesFromGroupedCurve References to elements outside the group were removed from a grouped curve element.
Public property Static member RevitUnableToUpadateGroups Unable to update groups for changes.
Public property Static member SomeGroupInstsBecameEmpty Group instances have had all their group members deleted and will also be deleted.
Public property Static member SomeMembersNotRestored Revit was not able to restore all of the requested group members. The members may depend on elements that are still excluded.
Public property Static member UnableToBindLink Unable to bind the selected links.
Public property Static member UnableToBindLinkInstances Unable to bind some link instances. Either linked file contains no 3d elements or there was an error loading its elements into the current project.
Public property Static member UnableToConvertGroupsToLinks Unable to convert the selected groups to links.
Public property Static member UnableToCreateAttachedGroup Unable to create attached detail group in view '[View Name]' for the selected elements.
Public property Static member UnableToDetachGroup Unable to detach the selected attached detail group(s).
Public property Static member UnableToExcludeElems Unable to exclude the selected group members.
Public property Static member UnableToGroupElems Revit does not allow grouping of some of the selected elements. These elements will not be included in the group.
Public property Static member UnableToLoadAttachedGroup Unable to load attached detail group '[Type Name]'.
Public property Static member UnableToLoadDetailGroup Unable to load detail group '[Type Name]'.
Public property Static member UnableToLoadGroup Unable to load file '[File Name]' as a group.
Public property Static member UnableToMaintainExclusions Unable to maintain exclusion of some group members. Some excluded members have been restored.
Public property Static member UnableToMaintainExclusionsWarn Unable to maintain exclusion of some group members. Some excluded members have been restored.
Public property Static member UnableToMoveElemsToProject Revit is unable to move the selected group members to the project.
Public property Static member UnableToRemapDetails Unable to create attached detail group in view '[View Name]' for the selected elements.
Public property Static member UnableToReplaceSelectedGroups Unable to change the types of the groups you have selected and the related groups. You might try deleting the groups you wish to change and placing or copy/pasting new groups of the desired type.
Public property Static member UnableToRestoreAllMembersOfGroups Revit is unable to restore the members of the selected groups.
Public property Static member UnableToSaveGroupType Unable to save group type.
Public property Static member UnableToTransferAttachedGroup Unable to load attached group [Type Name] of model group [Type Name].
Top
See Also