Find Method


Reference Intersector Find Method

Projects a ray from the origin along the given direction, and returns all references from intersected elements which match the ReferenceIntersector's criteria.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<ReferenceWithContext> Find(
	XYZ origin,
	XYZ direction
)

Parameters

origin XYZ
The origin of the ray.
direction XYZ
The direction of the ray.

Return Value

IList ReferenceWithContext
A collection containing the intersected references.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also