Element Get |
Returns ChangeType associated with a change in a parameter's value
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- parameterId ElementId
- ElementId of parameter for the ChangeType to trigger on.
Return Value
ChangeTypeChangeType that can be used to define a trigger for an Updater, triggering on parameter value change.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

remarks: Use this change type to trigger an Updater when the value of an element's parameter changes. Note: This change type will not trigger on newly created or deleted elements or on changes caused by Undo and Redo.