SurfaceBackgroundPatternId Property


Material Surface Background Pattern Id Property

The id of the FillPatternElement used as the background pattern of faces with this material in normal views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId SurfaceBackgroundPatternId { get; set; }

Property Value

ElementId
Exceptions
Exception Condition
ArgumentException When setting this property: The element id must represent a valid FillPatternElement. -or- When setting this property: The FillPattern target must be a drafting pattern.
ArgumentNullException When setting this property: A non-optional argument was null
Remarks
The FillPattern used for a background pattern must have a 'Drafting' target.
See Also