BuiltInFailures.GeometryFailures Class


Built In Failures Geometry Failures Class

Failures about GeometryFailures.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures GeometryFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class GeometryFailures

The BuiltInFailures GeometryFailures type exposes the following members.

Properties
Name Description
Public property Static member CannotFindClosest Cannot find closest points within lines.
Public property Static member ConvertFaceRegionsToFacesCrashed Failed to replace an instance face with its face regions.
Public property Static member ConvertFaceRegionsToFacesFailed Failed to replace an instance face with its face regions.
Public property Static member CurveAndSurfaceDoNotIntersect Curve and Surface do not intersect.
Public property Static member CurveDriverError Element's internal join data is corrupt.
Public property Static member CurveProjectTooShort The projection of the line in this view is too short to create a new Line
Public property Static member ElementIsTooThin [Element] is too thin.
Public property Static member ElementTooSmall Element is too small on screen
Public property Static member FailedReplaceCurveElemCurveDriver Failed to replace curve elem curve driver.
Public property Static member FailedUpdateCurveChain Failed to update curve chain.
Public property Static member FailToConvertLine Unable to convert lines
Public property Static member LineArcTangentFailure Can't keep arc element and straight line element tangent.
Public property Static member OffsetFaceFailed Failed to offset the face.
Public property Static member PolygonSegmentTooShort Polygon segment too short
Public property Static member SiteInvisible Topographic elements are not visible in your current view. You can modify View Range settings in the view's Properties or Visibility settings in Visibility/Graphics.
Public property Static member SuccessToConvertLine Success to convert lines
Public property Static member SymbolicLineInvalidPlane Symbolic Element refers to a Work Plane with unacceptable normal.
Public property Static member TooManyFacesEdges This family instance has too many [Edges and Faces]. Remove unnecessary geometry or split the instance into multiple instances.
Top
See Also