PlanTopologies Property (Phase)


Document Plan Topologies(Phase) Property

Gets the PlanTopologies of the current project in a given phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public PlanTopologySet this[
	Phase phase
] { get; }

Parameters

phase Phase
The phase of the Plan Topology.

Property Value

PlanTopologySet
Remarks
Accessing plan topologies requires that document is modifiable as it will actually trigger calculating plan topologies if they have not been calculated yet. The time necessary for the calculations may be significant and should be considered.
See Also