Show Method


Filter Dialog Show Method

Shows the FilterDialog editing dialog to the user.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void Show()
Remarks

If an existing FilterElement id was set during construction of the object or through the FilterToSelect property, that FilterElement will be selected for editing.

If a new filter name was set during construction of the object or through the NewFilterName property, a new ParameterFilterElement will be created and that new element will be selected for editing. If this option was chosen, the id of the explicitly create new filter will be stored in the NewFilterId property.

Note that the user may opt to add, delete or edit any of the available filter elements (or make no changes at all). To monitor which filters have been changed, use other Revit API mechanisms such as Dynamic Update or the DocumentChanged event.

See Also