Workset |
A filter used to match worksets of the given WorksetKind.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The WorksetKindFilter type exposes the following members.

Name | Description | |
---|---|---|
![]() | WorksetKindFilter(WorksetKind) | Constructs a new instance of WorksetKindFilter filter to match worksets of the given WorksetKind. |
![]() | WorksetKindFilter(WorksetKind, Boolean) | Constructs a new instance of WorksetKindFilter filter to match worksets of the given WorksetKind. |

Name | Description | |
---|---|---|
![]() | IncludeStandaloneWorksetsOnly | True if the results of the filter only match stand-alone worksets; worksets that are not stand-alone will be rejected. (Inherited from WorksetFilter ) |
![]() | Inverted | True if the results of the filter are inverted; worksets that would normally be accepted by this filter will be rejected, and worksets that would normally be rejected will be accepted. (Inherited from WorksetFilter ) |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. (Inherited from WorksetFilter ) |
![]() | WorksetKind | The WorksetKind. |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from WorksetFilter ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

This filter is a quick filter.