Create Method (Document, ElementId, Curve, XYZ, XYZ, LineLoadType)


Line Load Create(Document, Element Id, Curve, XYZ, XYZ, Line Load Type) Method

Creates a new custom line load within the project.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static LineLoad Create(
	Document document,
	ElementId hostElemId,
	Curve curve,
	XYZ forceVector1,
	XYZ momentVector1,
	LineLoadType symbol
)

Parameters

document Document
Document to which new line load will be added.
hostElemId ElementId
The analytical host element for the line Load.
curve Curve
Curve of the line load.
forceVector1 XYZ
The applied 3d force vector.
momentVector1 XYZ
The applied 3d moment vector.
symbol LineLoadType
The symbol of the LineLoad. Set to use default type.

Return Value

LineLoad
If successful, returns the newly created LineLoad, otherwise.
Exceptions
Exception Condition
ArgumentException The element hostElemId does not exist in the document -or- hostElemId is not permitted for this type of load. -or- The provided curve is not supported. -or- The input curve is not bound.
ArgumentNullException A non-optional argument was null
ArgumentsInconsistentException Thrown when all force and moment vectors are equal zero.
InvalidOperationException Thrown if type could not be set for newly created line load.
Remarks
The curve must be bounded. The curve can be:
  • Line
  • Arc
  • Ellipse
See Also