PhotometricWebLightDistribution Class


Photometric Web Light Distribution Class

This class encapsulates a photometric web light distribution.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Lighting LightDistribution
Autodesk.Revit.DB.Lighting PhotometricWebLightDistribution

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PhotometricWebLightDistribution : LightDistribution

The PhotometricWebLightDistribution type exposes the following members.

Constructors
Name Description
Public method PhotometricWebLightDistribution(PhotometricWebLightDistribution) Creates a copy of the given photometric web light distribution
Public method PhotometricWebLightDistribution(String, Double) Creates a photometric web light distribution object with the given filename and tilt.
Top
Properties
Name Description
Public property PhotometricWebFile The filename of an IES photometric web file.
Public property TiltAngle The tilt angle.
Top
Methods
Name Description
Top
See Also