SetPoints Method


Curve By Points Set Points Method

Change the sequence of points interpolated by this curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetPoints(
	ReferencePointArray points
)

Parameters

points ReferencePointArray
An array of 2 or more ReferencePoints.
Exceptions
Exception Condition
ArgumentException Thrown when the array contains fewer than 2 points, when the array contains duplicates, or when adjacent points are located too close together.
See Also