GetUpdatedStraightsFromValidateConnections Method


Fabrication Configuration Get Updated Straights From Validate Connections Method

Get the set of element identifiers of fabrication part straights that were previously updated. If there were no straights were updated it will return an empty set of element identifiers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ISet<ElementId> GetUpdatedStraightsFromValidateConnections()

Return Value

ISet ElementId
Returns the set of element identifiers of fabrication part straights that were updated.
Remarks
The set of element identifiers were created by calling ValidateConnectionsForAllFabricationParts with the option updateGapForStraights set to true.
See Also