IsAcceptableStartingView Method


Starting View Settings Is Acceptable Starting View Method

Checks whether the given Id is an acceptable starting view. InvalidElementId corresponds to "Last Viewed" and is therefore also acceptable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsAcceptableStartingView(
	ElementId viewId
)

Parameters

viewId ElementId
The Id of the element to check.

Return Value

Boolean
True if the view is acceptable, False if it is not.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Model views (such as plans, ceiling plans, sections, elevations, and 3d views) are acceptable. In addition, drafting views, sheets, legends, schedules, and graphical column schedules are generally acceptable. Special views such as the project browser, system navigator, reports, revision schedules, internal schedules, sheets that are not actually in use, and views that belong to a family are not acceptable.
See Also