ListType Enumeration


List Type Enumeration

An enumerated type indicating the style of list item for paragraphs that are part of ordered or unordered lists in FormattedText .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ListType
Members
Member name Value Description
ArabicNumbers 3 The paragraph is a part of an ordered list with Arabic number headings.
Bullet 2 The paragraph is a part of a bulleted list.
LowerCaseLetters 4 The paragraph is a part of an ordered list with lower-case letter headings.
Mixed 0 This value may be returned by FormattedText.GetListType() when there are multiple list types in the selected range.
None 1 The paragraph is not a part of a list.
UpperCaseLetters 5 The paragraph is a part of an ordered list with upper-case letter headings.
See Also