SetBoxCenter Method


Viewport Set Box Center Method

Moves this viewport so that the center of the box outline (excluding the viewport label) is at a given point.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetBoxCenter(
	XYZ newCenterPoint
)

Parameters

newCenterPoint XYZ
The desired center for the box outline.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException The viewport is not on a sheet.
See Also