ParameterDownloadOptions Class


Parameter Download Options Class

An option class used for downloading parameters from the Parameters Service.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB ParameterDownloadOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ParameterDownloadOptions : IDisposable

The ParameterDownloadOptions type exposes the following members.

Constructors
Name Description
Public method ParameterDownloadOptions Default constructor.
Public method ParameterDownloadOptions(ISet ElementId , Boolean, Boolean, ForgeTypeId) Initializes a new instance of the ParameterDownloadOptions class
Top
Properties
Name Description
Public property IsInstance True if binding to Element instances, false if binding to Element types.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Visible True if the parameter is visible to the user, false if it is hidden and accessible only via the API.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ParameterDownloadOptions
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetCategories Get categories for binding.
Public method GetGroupTypeId Get properties palette group identifier.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetCategories
Public method SetGroupTypeId Set properties palette group identifier.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also