Vertex |
Constructs the vertex from a point, a normal vector, and a color.
Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public VertexPositionNormalColored(
XYZ position,
XYZ normal,
ColorWithTransparency color
)
Parameters
- position XYZ
- The vertex's position.
- normal XYZ
- The vertex's normal vector.
- color ColorWithTransparency
- The vertex's color.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |