FilterToSelect Property


Filter Dialog Filter To Select Property

The filter element to be selected once Show is invoked.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId FilterToSelect { get; set; }

Property Value

ElementId
The default is InvalidElementId, resulting in selecting the first available (if any) FilterElement.
Exceptions
Exception Condition
ArgumentException When setting this property: The supplied ElementId id is not of a FilterElement.
ArgumentNullException When setting this property: A non-optional argument was null
See Also