IFCGeometryInfo Class


IFCGeometry Info Class

A container class for Revit geometry extracted from an element.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.IFC IFCGeometryInfo

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCGeometryInfo : IDisposable

The IFCGeometryInfo type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Static member CreateCurveGeometryInfo Creates a new container object which holds IfcCurve handles processed from a Revit geometry object.
Public method Static member CreateFaceGeometryInfo(Double) Creates a new container object which holds IfcFace handles processed from a Revit geometry object.
Public method Static member CreateFaceGeometryInfo(Double, Boolean) Creates a new container object which holds IfcFace handles processed from a Revit geometry object.
Public method Static member CreateFaceGeometryInfo(ExporterIFC, Plane, XYZ, Double, Boolean) Creates a new container object which holds IfcFace handles processed from a Revit geometry object.
Public method Static member CreateSurfaceGeometryInfo Creates a new container object which holds IfcSurface handles processed from a Revit geometry object.
Public method Dispose Releases all resources used by the IFCGeometryInfo
Public method GetCurves Gets the IfcCurve handles created representing the processed geometry and stored in this object.
Public method GetFaces Gets the IfcFace handles created representing the processed geometry and stored in this object.
Public method GetRepresentations Gets the representation handles created representing the processed geometry and stored in this object.
Public method GetSurfaces Gets the IfcSurface handles created representing the processed geometry and stored in this object.
Top
See Also