AddOption Method


IFCExport Options Add Option Method

Adds a new named option to the options structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddOption(
	string name,
	string value
)

Parameters

name String
The option name.
value String
The option value.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
Named options can be used to set options not accessible through the standard IFC export user interface. It is up to the implementation of the IExporterIFC interface to customize export behavior based on these options.
See Also