View |
This validator checks that the parent view is appropriate for callout views.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool IsParentViewValidForCallout(
Document document,
ElementId parentViewId
)
Parameters
- document Document
- The document which contains the ViewFamilyType and parent view.
- parentViewId ElementId
- The view in which the new callout will appear. Callouts can be created in FloorPlan, CeilingPlan, StructuralPlan, Section, Elevation, and Detail views.
Return Value
BooleanTrue if the ViewFamilyType can be used for callout views in the parent view, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |