IFCTransformSetter Class


IFCTransform Setter Class

A state-based class that forces an extra transformation applied to objects being exported.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.IFC IFCTransformSetter

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class IFCTransformSetter : IDisposable

The IFCTransformSetter type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method Static member Create Creates a new instance of a transform setter.
Public method Dispose Releases all resources used by the IFCTransformSetter
Public method Initialize Initializes the transformation in the transform setter.
Public method InitializeFromBoundingBox
Top
Remarks
IFC has a system of local placements; these are created from a set of transforms in Revit. Sometimes there is a need to create a 'fake' transform to get the right local placement structure for IFC. This class is intended to maintain the transformation for the duration that it is needed. To ensure that the lifetime of the object is correctly managed, you should declare an instance of this class as a part of a 'using' statement in C# or similar construct in other lanuguages.
See Also