Solid |
A class containing optional information to control the properties of the Solid generated by the GeometryCreationUtilities routines.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The SolidOptions type exposes the following members.

Name | Description | |
---|---|---|
![]() | SolidOptions | Creates a new SolidOptions class with material and graphics style settings. |

Name | Description | |
---|---|---|
![]() | ExtraFaceAndEdgeHistoryKey | Optional extra key used to create face and edge histories for the Solid. If extraFaceAndEdgeHistoryKey is higher than -1, the Solid's face and edge histories will be created depending on the geometry generation of the Solid. |
![]() | GraphicsStyleId | Defines the graphics style id for the Solid. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | MaterialId | Defines the material id for the Solid. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the SolidOptions |