Flip Method


Fabrication Part Flip Method

Flips the fabrication part that is directionally oriented (tees, crosses, valves, dampers, etc.) to the opposite direction.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool Flip()

Return Value

Boolean
Returns true if successful otherwise false if the fabrication part cannot be flipped.
Exceptions
Exception Condition
InvalidOperationException It is not a valid part that can be flipped.
Remarks
Existing connections will be maintained, disconnect warnings will be posted if the connection cannot be maintained.
See Also