RebarContainerItem Class


Rebar Container Item Class

Provides implementation for Rebar stored in RebarContainer.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Structure RebarContainerItem

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class RebarContainerItem : IDisposable

The RebarContainerItem type exposes the following members.

Properties
Name Description
Public property ArrayLength Identifies the distribution path length of rebar set.
Public property BarsOnNormalSide Identifies if the bars of the rebar set are on the same side of the rebar plane indicated by the normal.
Public property BarTypeId The identifier of the rebar bar type.
Public property BaseFinishingTurns For a spiral, the number of finishing turns at the lower end of the spiral.
Public property Height For a spiral, the overall height.
Public property IncludeFirstBar Identifies if the first bar in rebar set is shown.
Public property IncludeLastBar Identifies if the last bar in rebar set is shown.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property ItemIndex The index of this item in its associated RebarContainer.
Public property LayoutRule Identifies the layout rule of rebar set.
Public property MaxSpacing Identifies the maximum spacing between rebar in rebar set.
Public property MultiplanarDepth For a multiplanar rebar, the depth of the instance.
Public property Normal A unit-length vector normal to the plane of the rebar
Public property NumberOfBarPositions The number of potential bars in the set.
Public property Pitch For a spiral, the pitch, or vertical distance traveled in one rotation.
Public property Quantity Identifies the number of bars in rebar set.
Public property RebarShapeId The RebarShape element that defines the shape of the rebar.
Public property TopFinishingTurns For a spiral, the number of finishing turns at the upper end of the spiral.
Public property TotalLength The length of an individual bar multiplied by Quantity.
Public property Volume The volume of an individual bar multiplied by Quantity.
Top
Methods
Name Description
Public method CanApplyPresentationMode Checks if a presentation mode can be applied for this rebar in the given view.
Public method CanUseHookType Checks if the specified RebarHookType id is of a valid RebarHookType for the Rebar's RebarBarType
Public method ClearPresentationMode Sets the presentation mode for this rebar set to the default (either for a single view, or for all views).
Public method ComputeDrivingCurves Compute the driving curves.
Public method Dispose Releases all resources used by the RebarContainerItem
Public method DoesBarExistAtPosition Checks whether a bar exists at the specified position.
Public method FindMatchingPredefinedPresentationMode Determines if there is a matching RebarPresentationMode for the current set of selected hidden and unhidden bars assigned to the given view.
Public method GetBarPositionTransform Return a transform representing the relative position of any individual bar in the set.
Public method GetBendData Gets the RebarBendData, containing bar and hook information, of the instance.
Public method GetCenterlineCurves(Boolean, Boolean, Boolean) A chain of curves representing the centerline of the rebar.
Public method GetCenterlineCurves(Boolean, Boolean, Boolean, MultiplanarOption) A chain of curves representing the centerline of the rebar.
Public method GetDistributionPath The distribution path of a rebar set.
Public method GetHookOrientation Returns the orientation of the hook plane at the start or at the end of the rebar with respect to the orientation of the first or the last curve and the plane normal.
Public method GetHookTypeId Get the id of the RebarHookType to be applied to the rebar.
Public method GetPresentationMode Gets the presentaion mode for this rebar set when displayed in the given view.
Public method HasPresentationOverrides Identifies if this rebar set has overridden default presentation settings for the given view.
Public method IsBarHidden Identifies if a given bar in this rebar set is hidden in this view.
Public method IsRebarInSection Identifies if this rebar set is shown as a cross-section in the given view.
Public method SetBarHiddenStatus Sets the bar in this rebar set to be hidden or unhidden in the given view.
Public method SetFromCurves
Public method SetFromCurvesAndShape
Public method SetFromRebar Set an instance of a RebarContainerItem element according to a Rebar parameters. Will throw exception if given rebar is not shape driven. Will throw exception if given rebar has moved bars in set.
Public method SetFromRebarShape Set an instance of a RebarContainerItem element, as an instance of a RebarShape. The instance will have the default shape parameters from the RebarShape, and its location is based on the bounding box of the shape in the shape definition. Hooks are removed from the shape before computing its bounding box. If appropriate hooks can be found in the document, they will be assigned arbitrarily.
Public method SetHookOrientation Defines the orientation of the hook plane at the start or at the end of the rebar with respect to the orientation of the first or the last curve and the plane normal.
Public method SetHookTypeId Set the id of the RebarHookType to be applied to the rebar.
Public method SetLayoutAsFixedNumber Sets the Layout Rule property of rebar set to FixedNumber.
Public method SetLayoutAsMaximumSpacing Sets the Layout Rule property of rebar set to MaximumSpacing
Public method SetLayoutAsMinimumClearSpacing Sets the Layout Rule property of rebar set to MinimumClearSpacing
Public method SetLayoutAsNumberWithSpacing Sets the Layout Rule property of rebar set to NumberWithSpacing
Public method SetLayoutAsSingle Sets the Layout Rule property of rebar set to Single.
Public method SetPresentationMode Sets the presentation mode for this rebar set when displayed in the given view.
Top
See Also