SetRodLockedWithHost Method


Fabrication Rod Info Set Rod Locked With Host Method

Locks the rod with the host. The method is applicable only for bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetRodLockedWithHost(
	int rodIndex,
	bool locked
)

Parameters

rodIndex Int32
The index of the rod.
locked Boolean
Locks the rod with the host.
Exceptions
Exception Condition
ArgumentOutOfRangeException the index rodIndex is should be in range of rod count.
InvalidOperationException The hanger is not a bearer hanger.
See Also