ImportUnit Enumeration


Import Unit Enumeration

An enumerated type listing possible target units for CAD Import.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ImportUnit
Members
Member name Value Description
Centimeter 5 Centimeters as decimal values.
Custom 7 Custom values as decimal values
Decimeter 4 Decimeters as decimal values.
Default 0 Unit (if available) from the document that is getting imported.
Foot 1 Feet and Inches in fractional notation.
Inch 2 Inches in fractional notation.
Meter 3 Meters as decimal values.
Millimeter 6 Millimeters as decimal values.
USSurveyFoot 8 US survey feet as decimal values
See Also