BuiltInFailures.OpeningFailures Class


Built In Failures Opening Failures Class

Failures about Opening.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures OpeningFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class OpeningFailures

The BuiltInFailures OpeningFailures type exposes the following members.

Properties
Name Description
Public property Static member HostForCutHasNoGeometry Host can't be cut because it has no geometry.
Public property Static member HostForCutHasNoGeometryWarn Host can't be cut because it has no geometry.
Public property Static member InvalidComplexCut The family [Family Name] was containing one or more invalid cuts, which have been removed (most likely it was cutting a curtain wall). Please examine the family and make changes as needed.\r\nHint 1: If you are trying to cut a Curtain Wall, you may be able to achieve the desired result by editing the Elevation Profile or the curtain panel.\r\n Hint 2: If you can't see the family, you can still select it from the Project Browser.\r\nHint 3: This warning will disappear after you edit and then finish the family.
Public property Static member ModelAlreadyCheckedOutByUser The Cloud WorkSharing Model is already checked out by the current user.
Public property Static member OpeningCutAll Opening completely removes its host
Public property Static member OpeningDoesnotCutHost Opening does not cut its host.
Public property Static member OpeningDoesnotCutHostDelete Opening does not cut its host.
Public property Static member OpeningNegativeHeight The top of the Opening is lower than the bottom of the Opening or coincident with it.
Public property Static member OpeningPartiallyCutsHost Opening partially cuts its host.
Public property Static member OpeningRectDoesnotCutHost Rectangular opening doesn't cut its host.
Public property Static member OpeningRemovesHost Opening completely removes its host.
Public property Static member OpenStringerConflictNosing Open stringer can't be created for selected nosing profile. Set nosing profile to default to get open stringers created.
Public property Static member PropertyNotClosed Property lines do not form a closed loop. Area will not be computed.
Top
See Also