AdaptiveComponentInstanceUtils Class


Adaptive Component Instance Utils Class

An interface for Adaptive Component Instances.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB AdaptiveComponentInstanceUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class AdaptiveComponentInstanceUtils

The AdaptiveComponentInstanceUtils type exposes the following members.

Methods
Name Description
Public method Static member CreateAdaptiveComponentInstance Creates a FamilyInstance of Adaptive Component Family.
Public method Static member GetInstancePlacementPointElementRefIds Gets Placement Adaptive Point Element Ref ids to which the instance geometry adapts.
Public method Static member GetInstancePointElementRefIds Gets Adaptive Point Element Ref ids to which the instance geometry adapts.
Public method Static member GetInstanceShapeHandlePointElementRefIds Gets Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.
Public method Static member HasAdaptiveFamilySymbol Verifies if a FamilyInstance has an Adaptive Family Symbol.
Public method Static member IsAdaptiveComponentInstance Verifies if a FamilyInstance is an Adaptive Component Instance.
Public method Static member IsAdaptiveFamilySymbol Verifies if a FamilySymbol is a valid Adaptive Family Symbol.
Public method Static member IsInstanceFlipped Gets the value of the flip parameter on the adaptive instance.
Public method Static member MoveAdaptiveComponentInstance Moves Adaptive Component Instance by the specified transformation.
Public method Static member SetInstanceFlipped Sets the value of the flip parameter on the adaptive instance.
Top
See Also