Message |
An object that represents a simple message box that prompts the user for some action.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.UI.Events DialogBoxData
Autodesk.Revit.UI.Events MessageBoxData
Autodesk.Revit.DB APIObject
Autodesk.Revit.UI.Events DialogBoxData
Autodesk.Revit.UI.Events MessageBoxData
Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The MessageBoxData type exposes the following members.

Name | Description | |
---|---|---|
![]() | DialogType | An integer that describes the standard windows type of the dialog box. |
![]() | Message | The message that has been displayed in the dialog box. |

Name | Description | |
---|---|---|

When the application receives this object, a simple message box is displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.