Message |
An object that represents a simple message box that prompts the user for some action.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.UI.Events DialogBoxData
Autodesk.Revit.UI.Events MessageBoxData
Autodesk.Revit.DB APIObject
Autodesk.Revit.UI.Events DialogBoxData
Autodesk.Revit.UI.Events MessageBoxData
Namespace: Autodesk.Revit.UI.Events
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The MessageBoxData type exposes the following members.

Name | Description | |
---|---|---|
![]() | DialogType | An integer that describes the standard windows type of the dialog box. |
![]() | HelpId | An ID that represents the dialog that has been displayed. (Inherited from DialogBoxData ) |
![]() ![]() | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject ) |
![]() | Message | The message that has been displayed in the dialog box. |

Name | Description | |
---|---|---|
![]() | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject ) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | OverrideResult | Call this method to cause the Autodesk Revit dialog to be dismissed with the specified return value. (Inherited from DialogBoxData ) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |

When the application receives this object, a simple message box is displayed in Revit that requires user interaction. The OverrideResult function can be used to cause the dialog to be dismissed and return a desired result code.