CircuitPathMode Property


Electrical System Circuit Path Mode Property

The circuit path mode of the electrical system.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElectricalCircuitPathMode CircuitPathMode { get; set; }

Property Value

ElectricalCircuitPathMode
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
InvalidOperationException When setting this property: The electrical system circuit path does not have customized path, so the CircuitPathMode cannot be set as Custom.
See Also