LoadFamilySymbol Method (String, String)


Document Load Family Symbol(String, String) Method

Loads only a specified family type/symbol from a family file into the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool LoadFamilySymbol(
	string filename,
	string name
)

Parameters

filename String
The fully qualified filename of the Family file, usually ending in .rfa.
name String
The name of the type/symbol to be loaded, such as "W11x14".

Return Value

Boolean
True if the family type/symbol was loaded successfully into the project, otherwise False.
Exceptions
Exception Condition
ArgumentException Thrown when filename or name is or empty.
Remarks
This function supports loading of types/symbols stored in the family, or those available in the family Type Catalog file.
See Also