Ribbon |
The RibbonItem object represents an item on RibbonPanel, can be a push-button or a pull-down which should contain the information for creating one RibbonItem.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

The RibbonItem type exposes the following members.

Name | Description | |
---|---|---|
![]() | Enabled | Gets or sets a value indicating whether the item is enabled. |
![]() | ItemText | Gets or sets the text displayed on the item. |
![]() | ItemType | Gets the item type. |
![]() | LongDescription | Long description of the command tooltip |
![]() | Name | The name of the item. |
![]() | ToolTip | The description that appears as a ToolTip for the item. |
![]() | ToolTipImage | The image to show as a part of the button extended tooltip |
![]() | Visible | Gets or sets a value indicating whether the item is visible. |

Name | Description | |
---|---|---|
![]() | Equals | Determines whether the specified Object is equal to the current Object . (Overrides Object Equals(Object) ) |
![]() | GetContextualHelp | Gets the contextual help bound with this control. |
![]() | SetContextualHelp | Sets the contextual help bound with this button. |

This class is not supported in Revit Macros.

Reference