Element Demolished |
Id of a Phase at which the Element was demolished.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)


Exception | Condition |
---|---|
ArgumentException | When setting this property: The element does not allow setting the property DemolishedPhaseId to the value of demolishedPhaseId. -or- When setting this property: Invalid order of phases: An object cannot be demolished before it was created. |
ArgumentNullException | When setting this property: A non-optional argument was null |
InvalidOperationException | When setting this property: The element does not have properties CreatedPhaseId and DemolishedPhaseId. -or- When setting this property: The element does not allow setting the properties CreatedPhaseId and DemolishedPhaseId. |

After setting the property, DemolishedPhaseId regeneration can fail if CreatedPhaseId and DemolishedPhaseId are out of order with respect to their index in the property Document.Phases . Can be set to invalid element id.