StructuralDepth Property


Stairs Run Type Structural Depth Property

The structural depth of the stairs run, only available for monolithic stairs run.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double StructuralDepth { get; set; }

Property Value

Double
The structural depth of the stairs run, 0.0 if the stairs run is not monolithic.
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: The given value for structuralDepth must be between 0 and 30000 feet.
InvalidOperationException When setting this property: The stairs run type is not a monolithic type so the data being set is not applicable.
See Also