Solid Class


Solid Class

A 3d solid.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class Solid : GeometryObject

The Solid type exposes the following members.

Properties
Name Description
Public property Edges The edges that belong to the solid.
Public property Faces The faces that belong to the solid.
Public property SurfaceArea Returns the total surface area of this solid.
Public property Volume Returns the signed volume of this solid.
Top
Methods
Name Description
Public method ComputeCentroid Returns the Centroid of this solid.
Public method GetBoundingBox Retrieves a box that circumscribes the solid geometry.
Public method IntersectWithCurve Calculates and returns the intersection between a curve and this solid.
Top
Remarks
A solid is defined by the faces and edges that form its boundary.
See Also