GetCallingDocumentModelPath Method


External Resource Browser Data Get Calling Document Model Path Method

Returns a copy of the ModelPath of the document that is requesting the external resource browser data.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ModelPath GetCallingDocumentModelPath()

Return Value

ModelPath
A copy of the ModelPath of the document that is requesting the external resource browser data.
Exceptions
Exception Condition
InvalidOperationException The document requesting the external resource browser data does not have a ModelPath, either because it is detached, or because it has not been saved to disk yet, or no document specified.
See Also