BuiltInFailures.SiteFailures Class


Built In Failures Site Failures Class

Failures about Site.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures SiteFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class SiteFailures

The BuiltInFailures SiteFailures type exposes the following members.

Properties
Name Description
Public property Static member BuildingPadNotConnected Can't create a single Pad with several connected regions.
Public property Static member BuildingPadOverlap Pads can't overlap (but can share edges).
Public property Static member CannotComputeProperArea Property Lines must close. Area will not be computed.
Public property Static member CannotIntersectSiteRegions Subregions cannot intersect.
Public property Static member CannotMakeSurface Can't construct surface.
Public property Static member ContourLabelEmpty Contour Label doesn't intersect any contours.
Public property Static member EnterValueOrFormula Enter a value or a formula starting with '='.
Public property Static member GradingInSamePhase The Surface being Graded was created in the current Phase. Grading it will result in it being created and destroyed in the same Phase.
Public property Static member NoHostForSubregion This Subregion now does not appear to overlap any Toposurface with an appropriate Phase and Design Option.
Public property Static member NoHostForSubregionWarn This Subregion now does not appear to overlap any Toposurface with an appropriate Phase and Design Option.
Public property Static member NotEnoughPointsInSurface The surface must have at least three distinct Points.
Public property Static member PointNotInSurface A Point is outside of the Surface boundary. Insert the Point on the boundary instead, and then drag it to the desired location.
Public property Static member PointRelativeOutside In order to place Points relative to the existing Surface, the Point must be placed within the area of the existing Surface. The height of the new Point will be relative to the current Surface elevation at that Point.
Public property Static member PropertyIntersect Property lines intersect. Area calculations will not be precise.
Public property Static member RegionPhaseMismatch Subregions must have the same Phase Created parameter and Phase Demolished parameter as the host Toposurface. Subregion phase will be set to match the Toposurface.
Public property Static member ResetToposurfacePhaseCreated The parameter Phase Created of the Toposurface is not set to the first Phase. No pre-existing toposurface were detected. The parameter will be reset to the first Phase unless Keep Phase Created option is picked.
Public property Static member SiteEditPointsClipped Portions of the topographic surface or points on the surface may not be visible in this view due to clipping by the view.
Public property Static member SiteEditPointsInvisible Topographic elements are not visible in your current view. You can modify View Range settings in the view's Properties or Visibility settings in Visibility/Graphics. It is often easier to edit topography in a Site view or a 3D view.
Public property Static member SiteMergeDisconnected The two surfaces you are trying to merge are disconnected from one another. They should overlap, or at least share edges.
Public property Static member SitePhasesDontOverlap The phases of the two surfaces you are merging do not overlap. You can continue the operation, or cancel it and select a different pair of surfaces.
Public property Static member SiteRegionOptionConflict Subregions must be in the same Design Option as their Toposurface.
Public property Static member SurfaceSelfIntersection The splitting boundary drawn would result in a self-intersection of the surface boundary. Please edit your splitting lines to correct the problem.
Public property Static member SurfaceSplit The splitting boundary must split the Surface into exactly two pieces.
Public property Static member SurfaceSplitError The splitting boundary must split the Surface into exactly two pieces.
Public property Static member SurfaceSplitNoIntersection The splitting boundary must divide the Surface into separate pieces. There may be a gap in the splitting Lines or the Sketch may be incomplete.
Public property Static member SurfaceTriangulationFailed The Site Surface failed to triangulate.
Public property Static member ToposolidSlopeExceedsThreshold Thickness of this Toposolid may be slightly inaccurate due to extreme Shape Editing. Dimensions to this element in sections and details may not accurately indicate the Thickness shown in Type Properties.
Top
See Also