ComponentClassification Enumeration


Component Classification Enumeration

An enumerated type lists all MEP component classification. This attribute describes the general purpose of the MEP part component, that is used for scheduling, tagging, filter, ODBC, and etc. One component classification may include more than one part type.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ComponentClassification
Members
Member name Value Description
Coupling 107 Coupling component classification
Cross 105 Cross component classification
Duct 2 Straight duct segment component classification
Elbow 101 Elbow component classification
Endcap 106 Cap component classification
Flange 109 Flange component classification
FlexDuct 12 Flex duct curve component classification
FlexPipe 11 Flex pipe curve component classification
Hanger 113 Hanger (supports) component classification
Pipe 1 Straight pipe segment component classification
Sensor 112 Sensor component classification
Sleeve 114 Sleeve (supports) component classification
Tap 103 Cap component classification
Tee 102 Tee component classification
Transition 104 Transition component classification
Undefined 0 Undefined component classification
Union 108 Union component classification
Valve 111 Valve component classification
Wye 110 Wye component classification
See Also