RenderingSettings Class


Rendering Settings Class

Represents the rendering settings for a 3d view.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB RenderingSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class RenderingSettings : IDisposable

The RenderingSettings type exposes the following members.

Properties
Name Description
Public property BackgroundStyle The enum value that controls the background style for rendering.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property LightingSource The lighting scheme type.
Public property PrinterResolution The resolution level when using printer.
Public property ResolutionTarget The resolution target.
Public property ResolutionValue The rendering resolution in dots per inch (DPI).
Public property UsesRegionRendering The bool value that indicates whether to use region rendering.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the RenderingSettings
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetBackgroundSettings Returns an object that represents the rendering background settings.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetRenderingImageExposureSettings Returns an object that represents the rendering image exposure settings.
Public method GetRenderingQualitySettings Returns an object that represents the rendering quality settings.
Public method GetRenderingRegionOutline Returns the outline of the rendering region.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetBackgroundSettings Changes the rendering background settings details for the current background style.
Public method SetRenderingImageExposureSettings Changes the rendering image exposure settings.
Public method SetRenderingQualitySettings Change rendering quality settings.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also