AssetProperty Class


Asset Property Class

Represents a property of material.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual AssetProperty
More

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AssetProperty : IDisposable

The AssetProperty type exposes the following members.

Properties
Name Description
Public property IsReadOnly Identifies if the object is read-only or modifiable. If true, the object may not be modified. If false, the object's contents may be modified.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property Name Get the name of the AssetProperty
Public property NumberOfConnectedProperties The number of currently connected properties.
Public property Type Returns the type of the AssetProperty
Top
Methods
Name Description
Public method AddConnectedAsset Adds a new connected asset attached to this asset property, if it allows it.
Public method Code example AddCopyAsConnectedAsset Makes a copy of the asset and connects it to this property.
Public method Dispose Releases all resources used by the AssetProperty
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetAllConnectedProperties Gets the list of the connected properties. Connected properties are the detachable properties of an AssetProperty. e.g. diffuse property can have texture as its connected property. It can also detach texture on runtime.
Public method GetConnectedProperty Gets one connected property with specified index.
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method Code example GetSingleConnectedAsset Gets the single connected asset attached to this asset property, if it exists.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Static member GetTypeName Get the name of the AssetProperty
Public method IsEditable Check if property can be edited.
Public method IsValidSchemaIdentifier Check that schema name is valid
Public method RemoveConnectedAsset Removes the connected asset attached to this asset property if any.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
AssetProperty is the base class or all other AssetProperty sub classes.
See Also
Inheritance Hierarchy